Support Site powered by DXC Technology

System Requirements and Information

Browser Requirements for the Observatory

Internet Explorer: version 8+
Firefox: version 14+
Chrome: version 20+
Opera: version 11+
Safari: version 4+

Email addresses to whitelist

@dxc.com
@info.spikescavell.net
@info.spikescavell.co.uk
@info.spikescavell.com
@spikescavell.net
@spikescavell.com
@spikescavell.co.uk

Other requirements

In order to play the Observatory Training Videos, you may need to install a browser plugin/extension to be able to play either MP4 or WMV embedded videos. You will also require an audio output (either via PC speakers, headphones or USB headset).
Please note, some organizations have IT restrictions in place which prevent users from downloading software. In cases like these, you may be unable to upgrade or install browsers and plugin/extensions directly. Please contact your IT manager for assistance.

Business Continuity Plan

Business Continuity Plan

Accessible Observatory

Accessible Observatory

Our Terms and Conditions and Privacy Policy

T&Cs for UK Public Sector T&Cs for UK Private Sector T&Cs for US Public Sector T&Cs for US Private Sector Privacy Policy

Observatory login details are required to download some of these resources.